Prepared by: Minhaz / IT Department
Storage Migration Activity from CX340 to DMX for Mediation /
Process Name / Process Owner / Version History / Prepared By / Revised by
Storage Migration Activity from CX340 to DMX / IT Director / Minhaz
Step 1: Install EMCom using the following command:
#swinstall -s /EMC/EMCom
#swinstall -s /EMC/EMComlm.HPUX _3.11.tar EMCom
#swlist | grep -i om
HPUX11i-OE-Ent B.11.23.0706 HP-UX Enterprise Operating Environment Component
EMCom HP.V3.11.0.14 EMC Open Migrator/LM (OM/LM)
Step 2: First run the Inquiry utility to find which disk belong to which VG
#./inq.hpux1100
…………………………………………………………….
………………………………………………………………
dev/rdsk/c19t0d0 :SYMMETRIX :5773 :4400042000 : 2880
/dev/rdsk/c19t4d2 :SYMMETRIX :5773 :44003a3000 : 71385600
/dev/rdsk/c19t4d3 :SYMMETRIX :5773 :44003ab000 : 71385600
……………………………………………….
……………………….
Step 3: Now create a script to crate PV’s using the “pvcreate “commands for desired LUN’s.
For Ex:
#vi pvcreate.txt
……………………………………………..
pvcreate -f /dev/rdsk/c19t4d4
…………………………………………………………………………………
……………………………………………………………
:wq!
# sh –x “pvcreate.txt”
Step 4: Now create new VG’s to simulate old VG’s:
# ll /dev/*/group
…………………………………..
……………………………………
#cd /dev
#mkdir vg _bill03_ora _DMX
#cd vg _bill03_ora _DMX
#mknod group c 64 0x080000
Repeat step4 to create “group” file for others VG
Step 5: Now create VG’s with
#vgcreate -p 255 -l 255 -s 64 -e 16000 /dev/vg _bill03_ora _DMX /dev/dsk/c19t4d2
Now extend the VG with desired PV’s
#vi vgextend.txt
………………………..
…………………….
vgextend vg_bill03_ora_DMX /dev/dsk/c19t4d5
………………………………..
………………………..
:wq!
#sh –x “vgextend.txt”
# lvcreate -l 1088 –n r -n lv_orabin /dev/vg _bill03_ora _DMX
[We use “–n r” option to off Bad Block]
# lvcreate -l 5440 –n r -n lv _arch /dev/vg _bill03 _ora _DMX
Repeat step5 to create other VG’s and corresponding LV’s
Step 6: Now start copy using OpenMigrator using following procedure:
#stormigrate list //List is there any session exist
#stormigrate create -session orabin //Create a session “orabin”
# stormigrate add -session orabin /dev/vg _bill03 _ora/rlv _orabin /dev/vg _bill03 _ora _DMX/rlv _orabin //Add two LV’s in orabin session
#stormigrate list
Session State
------
orabin Inactive
# stormigrate show -session orabin //Show status of “orabin” session
MB
Source Size Target
------
/dev/vg_bill03_ora/rlv_orabin 40960 /dev/vg_bill03_ora_DMX/rlv_orabin
Session Name: orabin
Session State: Inactive
Action Plan: N/A
Task States: N/A
Number of Pairs: 1
Total Source Size: 40960 MB
#stormigrate activate -session orabin //Activate “orabin” session
#stormigrate show -session orabin
Source Size Target
------
/dev/vg_bill03_ora/rlv_orabin 40960 /dev/vg_bill03_ora_DMX/rlv_orabin
Session Name: orabin
Session State: Active
Action Plan: None
Task States: Idle
Number of Pairs: 1
Total Source Size: 40960 MB
#stormigrate copy -session orabin //Start copy from old LV to new LV
#stormigrate show -session orabin
MB
Source Size Target
------
/dev/vg_bill03_ora/rlv_orabin 40960 /dev/vg_bill03_ora_DMX/rlv_orabin
Session Name: orabin
Session State: Active
Action Plan: Copy
Task States: Running
Number of Pairs: 1
Total Source Size: 40960 MB
#stormigrate query -session orabin //Query copying progress
Now we need to wait for 100% copy done
Step 7: When 100% copy has finished we need to unmount required mount points using the following commands:
For Ex:
#bdf
#fuser –ck /u01;umount /u01
………………………………………………..
………………………………………………..
#sync;sync;sync;sync;sync
Step 8: Now we need to deactivate and delete “copy” session.
**Note: Before deactivate copy session we need to stop application and database
#stormigrate list
Session State
------
orabin Active
arch Active
homes Active
cdr Active
backup Active
u01 Active
u02 Active
u04 Active
u03 Active
#vi session_list.txt
…………………
orabin
arch
……………….
………………
…………..
:wq!
#for i in `cat session_list.txt`
do
stormigrate deactivate -session $i
sleep 2
done
#stormigrate list
Session State
------
orabin Inactive
arch Inactive
homes Inactive
cdr Inactive
backup Inactive
u01 Inactive
u02 Inactive
u04 Inactive
u03 Inactive
#for i in `cat session _list.txt`
do
stormigrate delete -session $i
sleep 2
done
#stormigrate list
No sessions found
Step 9: Now we need to take map file of old VG’s and new DMX VG’s .Then deactivated and export them.
For Ex:
#vgexport –p –v –s –m /tmp/map/vg_bill03_ora.map /dev/vg_bill03_ora
# vgexport –p –v –s –m /tmp/map/vg_bill03_ora_DMX.map /dev/vg_bill03_ora_DMX
#vgdisplay –v |grep –i “VG Name”
#vgchange –a n /dev/vg_bill03_ora
#vgchange –a n /dev/vg_bill03_ora_DMX
………………………………………………………….
……………………………………………….
#vgexport /dev/vg_bill03_ora
#vgexport /dev/vg_bill03_ora_DMX
…………………………..
Step 10: Change the fiber cable from old switch to DMX switch
Step 11: Now create New VG’s “group” file.
#cd /dev
#mkdir vg_boll03_ora vg_boll03_ora ……………………
#ll /dev/*/group
#cd vg_boll03_ora
#mknod group c 64 0x010000
………………….
…………………………
Repeat step11 for other VG’s. After creating group file we need to remove CLARiiON storage dead path using the following coimmands:
#ioscan –fnC disk
#insf
#powermt check force
#powermt config
#powermt save
#powermt display
#powermt restore dev=all
Step 12: Now we need to import DMX VG’s map file with the name of old VG’s and activated them
#cd /tmp/map
#vgimport –s –m –v vg _bill03 _cdr _DMX.map /dev/vg_bill03_ora
#vgchange –a y /dev/vg_bill03_ora
#extendfs /dev/vg _bill03_ora/rlv _arch
#fsck –F vxfs –o full /dev/vg _bill03_ora/rlv _arch
………………………
……………………………..
……………………….
Repeat step12 for other VG’s
Step 13: Now we need to set IO Timeout parameter to 90 seconds of each DMX PV
#vgdisplay –v |grep -i /dev/dsk/c19t
PV Name /dev/dsk/c19t6d4
PV Name /dev/dsk/c19t6d5
PV Name /dev/dsk/c19t5d0
PV Name /dev/dsk/c19t5d1
PV Name /dev/dsk/c19t5d2
PV Name /dev/dsk/c19t5d3
PV Name /dev/dsk/c19t5d4
PV Name /dev/dsk/c19t5d5
PV Name /dev/dsk/c19t5d6
………………………..
......
#vi pvcgange.txt
......
......
pvchange –t 90 /dev/dsk/c19t6d4
pvchange –t 90 /dev/dsk/c19t6d5
......
......
:wq!
#sh –x ``pvchange.txt’’
#mount –a
#bdf
#cd /
#shutdown –ry 0
Step 14: After successful migration please remove "EMCom" software from system using the following command:
# swlist |grep -i emcom
EMCom HP.V3.11.0.14 EMC Open Migrator/LM (OM/LM)
#swremove EMCom
======07/09/09 09:11:16 BDST BEGIN swremove SESSION
(non-interactive) (jobid=blbillpr-0128)
* Session started for user "root@blbillpr".
* Beginning Selection
* Target connection succeeded for "blbillpr:/".
* Software selections:
EMCom.EMCom,l=/,r=HP.V3.11.0.14,a=HP-UX_B.11_00/11_11/11_23/11_31,v=EMC
* Selection succeeded.
* Beginning Analysis
* Session selections have been saved in the file
"/.sw/sessions/swremove.last".
* The analysis phase succeeded for "blbillpr:/".
* Analysis succeeded.
* Beginning Execution
* The execution phase succeeded for "blbillpr:/".
* Execution succeeded.
NOTE: More information may be found in the agent logfile using the
command "swjob -a log blbillpr-0128 @ blbillpr:/".
======07/09/09 09:11:27 BDST END swremove SESSION (non-interactive)
(jobid=blbillpr-0128)
#swlist |grep -i emcom
Storage Migration / Guideline for storage migration / Page 8 of 8