DHCP on a router

! UDP broadcasts coming in E0 will be forwarded as unicasts to 10.1.2.202.

! The source IP will be changed to 10.1.1.255, so that the reply packets will be

! broadcast back out E0.

interface Ethernet1

ip address 10.1.1.1 255.255.255.0

ip helper-address 10.1.2.202

! Below, an alternative configuration, with R1 as the DHCP server. R1 assigns IP

! addresses other than the excluded first 20 IP addresses in the subnet, and informs the

! clients of their IP addresses, mask, DNS, and default router. Leases are for 0 days,

! 0 hours, and 20 minutes.

ip dhcp excluded-address 10.1.1.0 10.1.1.20

!

ip dhcp pool subnet1

network 10.1.1.0 255.255.255.0

dns-server 10.1.2.203

default-router 10.1.1.1

lease 0 0 20

HSRP:

! First, on Router R1, a tracking object must be configured so that

! HSRP can track the interface state.

track 13 interface Serial0/0.1 line-protocol

! Next, on Router R1, two HSRP groups are configured. R1 has a higher priority

! in group 21, with R2 having a higher priority in group 22. R1 is set to preempt

! in group 21, as well as to track interface s0/0.1 for both groups.

interface FastEthernet0/0

ip address 10.1.1.2 255.255.255.0

standby 21 ip 10.1.1.21

standby 21 priority 105

standby 21 preempt

standby 21 track 13

standby 22 ip 10.1.1.22

standby 22 track 13

! Next, R2 is configured with a higher priority for HSRP group 22, and with

! HSRP tracking enabled in both groups. The tracking “decrement” used by R2,

! when S0/0.1 fails, is set to 9 (instead of the default of 10).

! A tracking object must be configured first, as on R1.

track 23 interface Serial0/0.1 line-protocol

interface FastEthernet0/0

ip address 10.1.1.1 255.255.255.0

standby 21 ip 10.1.1.21

standby 21 track 23

standby 22 ip 10.1.1.22

standby 22 priority 105

standby 22 track 23 decrement 9

Another HSRP

Switch(config-if)# standby group ip ip-address [secondary]

Switch(config-if)# standby group priority priority

Switch(config-if)# standby group timers [msec] hello [msec] holdtime

Switch(config-if)# standby group preempt [delay [minimum seconds] [reload seconds]]

Switch(config-if)# standby group authentication string

HSRP key chain for md5:

Switch(config-if)# standby group authentication md5 key-string [0 | 7] string

Switch(config)# key chain chain-name

Switch(config-keychain)# key key-number

Switch(config-keychain-key)# key-string [0 | 7] string

Switch(config)# interface type mod/num

Switch(config-if)# standby group authentication md5 key-chain chain-name

Tracking

Switch(config-if)# standby group track type mod/num [decrementvalue]

VRRP:

CatalystA(config)# interface vlan 50

CatalystA(config-if)# ip address 192.168.1.10 255.255.255.0

CatalystA(config-if)# vrrp 1 priority 200

CatalystA(config-if)# vrrp 1 ip 192.168.1.1

CatalystA(config-if)# vrrp 2 priority 100

CatalystA(config-if)# no vrrp 2 preempt

CatalystA(config-if)# vrrp 2 ip 192.168.1.2

GLBP:

Switch(config-if)# glbp group ip [ip-address [secondary]]

Switch(config-if)# glbp group priority level

Switch(config-if)# glbp group preempt [delay minimum seconds]

Switch(config-if)# glbp group timers [msec] hellotime [msec] holdtime

Switch(config-if)# glbp group timers redirect redirect timeout

GLBP tracking:

Switch(config)# track object-number interface type mod/num {line-protocol | ip routing}

Switch(config-if)# glbp group weighting maximum [lower lower] [upper upper]

Switch(config-if)# glbp group weighting track object-number [decrement value]

GLBP load balancing type

Switch(config-if)# glbp group load-balancing [round-robin | weighted | host-dependent]