Subnet: Planning Configuration

Subnet: Planning Configuration

Subnet: planning – configuration

Step-by-Step Procedure

Planning to build subnet(s)

  1. Self-asking questions:
  2. How many subnets am I going to build?
  3. What will be IP range – IP mask for each subnet?
  4. Which IP will be used for gateway on each subnet?
  5. What is the topology for my network?
  6. How many routers, switches, hubs will be used on my network?
  7. What will be connection structure for my network (computers-hubs-switches-routers)?
  1. Set up computers - hubs - switches
  • The following websites could give you some help on calculating range of IP and Netmask for your subnets:
  • Try to use the first available IP address in your IP range for default-gateway. For example: 192.168.10.1
  • Assign appropriate IP address, network mask and default gateway IP for every machine
  • Connect computers of the same subnet to the same (tree of) hub, switches
  • Connect hub or switch to the right interface on router

2.1.configuration TCP/IP on a Windows base machine

2.2.configuration TCP/IP on a Linux base machine

2.3.configuration TCP/IP on a Solaris machine

The simplest way to configure network information for a Solaris machine is doing it at installation time. The installer will ask you all information about IP, router, netmask, … and save them to the right place, into the right file. However if you need to reconfigure your network later, use following instructions.

All of following files need to be added WRITABLE mode under root privileges. Using command: chmod +w <filename>

Create or Edit file /etc/inet/netmasks. File content will be in following format:
<network number> / <net mask>
For example:
192.168.4.0 / 255.255.255.0
Create or Edit file (/etc/inet/hosts). File content will be in following format and contains at least localhost (127.0.0.1) and your machine:
<IP address: xxx.xxx.xxx.xxx> / <Host name> / <Alias>
For example:
127.0.0.1 / Localhost
192.168.4.5 / Solaris10_5 / Loghost
192.168.4.2 / Solaris10_2
192.168.4.3 / Linux9_3
Create or Edit file /etc/inet/ipnodes. File content will be in following format and contains at least localhost (127.0.0.1) and your machine:
For example:
127.0.0.1 / Localhost
192.168.4.5 / Solaris10_5 / Loghost
192.168.4.2 / Solaris10_2
192.168.4.3 / Linux9_3
Create or Edit file /etc/resolv.conf. File content should have at least your name server in following format:
<nameserver> / <IP address: xxx.xxx.xxx.xxx>
For example:
Solaris10_5 / 192.168.4.5
Create or Edit file /etc/defaultrouter. File content should have IP address of the gateway machine
For example:
192.168.4.1
Create or Edit file /etc/hostname.?????. Each network card on your machine will need to have one hostname file associate with it. This file will help to have the interface added and configured automatically at boot time. The file name has two parts: <hostname.<netcardtype>. For network card type, please check at sun.com website. The content of this file is name of your machine:
For example:
Solaris10_5
  1. Set up router (Cisco C2600)
  • The following basic items need to be configured for a router
  • Setup basic parameters

Router> enable

Router# setup

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: yes

At any point you may enter a question mark '?' for help.

Use ctrl-c to abort configuration dialog at any prompt.

Default settings are in square brackets '[]'.

Basic management setup configures only enough connectivity

for management of the system, extended setup will ask you

to configure each interface on the system

Would you like to enter basic management setup? [yes/no]: yes

Configuring global parameters:

Enter host name [Router]: GridRouter

The enable secret is a password used to protect access to

privileged EXEC and configuration modes. This password, after

entered, becomes encrypted in the configuration.

Enter enable secret: password

The enable password is used when you do not specify an

enable secret password, with some older software versions, and

some boot images.

Enter enable password: creugrid

The virtual terminal password is used to protect

access to the router over a network interface.

Enter virtual terminal password: password

Configure SNMP Network Management? [no]: no
Enter interface name used to connect to the
management network from the above interface summary: FastEthernet0/0
Configuring interface FastEthernet0/0:
Use the 100 Base-TX (RJ-45) connector? [yes]: yes
Operate in full-duplex mode? [no]: no
Configure IP on this interface? [yes]: yes
IP address for this interface []: 192.168.10.100
Subnet mask for this interface [] : 255.255.255.0
Class C network is 192.168.102.0, 24 subnet bits; mask is /24
[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
Enter your selection [2]: 2

  • Setup Interfaces [IP – net mask – duplex – status]

Router# config terminal

Router(config)# interface Fast0/0

Router(config-if)# ip address 192.168.11.100 255.255.255.0

Router(config-if)# duplex auto

Router(config-if)# no shutdown

Router(config-if)# keepalive

Router(config-if)# exit

Router(config)# interface Fast0/1

......

Router(config-if)# exit

repeat above steps for each individual interfaces that you want to configure

Router(config)# exit

  • Setup Router protocol [ router rip – version 2]

Router(config)# ip routing

Router(config)# router rip

Router(config-router)# version 2

Router(config-router)#network 192.168.10.0

Router(config-router)#network 192.168.11.0

Router(config-router)#exit

  • Save current configuration

Router(config)# exit

Router# copy run star

Destination filename [startup-config]?

Building configuration...

[OK]

Router#

  1. Example of GRID computing project sub-net


  1. Important notes
  • With machines that have more than 1 network cards and each network card was configured to connect to a different subnet-gateway, routing from one subnet to another on these machines may not success because of gateway confusing problem. (if that machine is not a router)

More information on Router protocol [ router rip – version 2]

(The following note is from Dr. Lee’s website about how to configure RIP)

After you set up your pod’s CISCO 2600 router, in order to advertise the existence of your subnet to devices outside of your subnet, you should use rip (Routing Information Protocol) as follows.

  • Please refer the diagram in the hint entitled “Frequently Used IOS Commands.” to understand how to go into the router configuration mode.
  • Type the following command to enter the router configuration mode.

router rip

  • Once you entered the router configuration mode, please type the following to set up the version of your rip protocol and advertise your subnet to devices in 190.111.0.0.

version 2

network 190.111.0.0

Section I.1router rip

To configure the Routing Information Protocol (RIP) routing process, use the router rip command in global configuration mode. To turn off the RIP routing process, use the no form of this command.

router rip

no router rip

Syntax Description

This command has no arguments or keywords.

Defaults

No RIP routing process is defined.

Section I.2Command Modes

Global configuration

Command History

Release / Modification
10.0 / This command was introduced.

Examples

The following example shows how to begin the RIP routing process:

router rip

Section I.3network (RIP)

To specify a list of networks for the Routing Information Protocol (RIP) routing process, use this form of the network command in router configuration mode. To remove an entry, use the no form of this command.

network network-number

no network network-number

Syntax Description

network-number / IP address of the network of directly connected networks.

Defaults

No networks are specified.

Section I.4Command Modes

Router configuration

Command History

Release / Modification
10.0 / This command was introduced.

Usage Guidelines

The network number specified must not contain any subnet information. There is no limit to the number of network commands you can use on the router. RIP routing updates will be sent and received only through interfaces on this network.

RIP sends updates to the interfaces in the specified networks. Also, if an interface's network is not specified, it will not be advertised in any RIP update.

Examples

The following example defines RIP as the routing protocol to be used on all interfaces connected to networks 10.99.0.0 and 192.168.7.0:

router rip

network 10.99.0.0

network 192.168.7.0

Section I.5version

To specify a RIP version used globally by the router, use theversion command in router configuration mode. Use the no form of this command to restore the default value.

version {1|2}

no version

Syntax Description

1 / Specifies RIP Version 1.
2 / Specifies RIP Version 2.

Defaults

The software receives RIP Version 1 and Version 2 packets, but sends only Version 1 packets.

Section I.6Command Modes

Router configuration

Command History

Release / Modification
11.1 / This command was introduced.

Usage Guidelines

To specify RIP versions used on an interface basis, use the ip rip receive version and ip rip send version commands.

Examples

The following example enables the software to send and receive RIP Version 2 packets:

version 2

Step-by-Step Procedure to recover lost password of Cisco C2600 router

(

To recover your password, complete these steps:

  1. Attach a terminal or PC with terminal emulation to the console port of the router. Use these terminal settings:
  2. 9600 baud rate
  3. No parity
  4. 8 data bits
  5. 1 stop bit
  6. No flow control

For more information on cabling, and details about how to connect a terminal to the console port or the AUX port, visit these links:

Cabling Guide for Console and AUX Ports on Cisco Routers

Connect a Terminal to Catalyst 2948G-L3, 4908G-L3, and 4840G Series Switches

Catalyst 8510CSR, and 8540CSR Switches Console Port Pinouts

  1. If you still have access to the router, type show version, and record the setting of the configuration register. It is usually 0x2102 or 0x102. For a sample output of the show version command, refer to the Example of Password Recovery Procedure section.
  1. If you do not have access to the router (because of a lost login or TACACS password), you can safely consider that your configuration register is set to 0x2102. Use the power switch to turn off the router, and then turn it back on.

Important: To simulate step 4 on a Cisco 6400, pull out and then replace the Node Route Processor (NRP) or Node Switch Processor (NSP) card.

Important: To simulate step 4 on a Cisco 6x00 using NI-2, pull out and then replace the NI-2 card.

  1. Press Break or (Ctrl + Break) on the terminal keyboard within 60 seconds of the power-up to put the router into ROMMON. If the break sequence does not work, see Standard Break Key Sequence Combinations During Password Recovery for other key combinations.
  1. Type confreg 0x2142 at the rommon 1> prompt to boot from Flash without loading the configuration.
  1. Type reset at the rommon 2> prompt. The router reboots but ignores its saved configuration.
  1. Type no after each setup question or press Ctrl-C to skip the initial setup procedure.
  1. Type enableat the Router> prompt. You are taken to the enable mode, and the Router# prompt appears.

Important: Type configure memory or copy startup-config running-config to copy the nonvolatile RAM (NVRAM) into memory.

Do nottype configure terminal.

  1. Type write terminalor show running-config.

The show running-config and write terminal commands show the configuration of the router. In this configuration you see under all the interfaces the shutdown command, which means all interfaces are currently shutdown. Also, you can see the passwords (enable password, enable secret, vty, console passwords, and so on) either in encrypted or unencrypted format. The unencrypted passwords can be re-used, the encrypted ones will have to be changed with a new one.

  1. Type configure terminaland make the changes. The prompt is now hostname(config)#.
  1. Type enable secretpassword to change the enable secret password, for example.

Issue the no shutdown command on every interface that is used.

If you issue a show ip interface brief command, every interface that you want to use should be "up up".

  1. Type config-register 0x2102, or the value you recorded in step 2.

Press Ctrl-Z or end to leave the configuration mode.

The prompt is now changed to hostname#.

  1. Type write memory or copy running-config startup-config to commit the changes.

Page 1