KARPAGAM ACADEMY OF HIGHER EDUCATION

(Deemed University Established Under Section 3 of UGC Act, 1956)

Coimbatore – 641 021.

Department Of Computer Applications

MASTER OF COMPUTER APPLICATIONS

NETWORK SIMULATOR LAB

(15CAP513N)

lab manual

  1. SIMPLE ROUTER CONFIGURATION

AIM :

To create Basic configuration for Router.

ALGORITHM :

STEP 1: Start the configuration.

STEP 2: create topology with router 1841.

STEP 3: Enter the user mode and then privilege mode.

STEP 4: Set host name in the configuration mode.

STEP 5: Exit from configuration mode.

STEP 6: Stop the configuration

PROGRAM:

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: n

Press RETURN to get started!

Router>en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname Router0

Router0(config)#enable secret class

Router0(config)#line console 0

Router0(config-line)#password CISCO

Router0(config-line)#login

Router0(config-line)#exit

Router0(config)#line vty 0 4

Router0(config-line)#password CISCO

Router0(config-line)#login

Router0(config-line)#exit

Router0(config)#interface FastEthernet0/0

Router0(config-if)#ip address 192.168.1.1 255.255.255.0

Router0(config-if)#no shutdown

Router0(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router0(config-if)#exit

Router0(config)#interface FastEthernet0/1

Router0(config-if)#ip address 192.168.2.1 255.255.255.0

Router0(config-if)#no shutdown

Router0(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router0(config-if)#

Router0(config-if)#exit

Router0(config)#exit

Router0#

%SYS-5-CONFIG_I: Configured from console by console

Router0#show ip interface brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 192.168.1.1 YES manual up up

FastEthernet0/1 192.168.2.1 YES manual up up

Vlan1 unassigned YES unset administratively down down

Router0#

Router0#%IP-4-DUPADDR: Duplicate address 192.168.1.1 on FastEthernet0/0, sourced by 0090.21BC.C3C2

OUTPUT:

2.ACCESS AND UTILIZE THE ROUTER TO SET BASIC PARAMETERS

AIM :

To set basic parameters for Router.

ALGORITHM :

STEP 1: Start the program.

STEP 2: Create topology by using router 1841.

STEP 3: Connect switches to both the ports of the router.

STEP 4: Enter User mode and configuration mode.

STEP 5: Set the IP address for faster other set and serial port for the router.

STEP 6: Set the link and change the link into mode.

STEP 7: Enter from the configuration mode.

STEP8: Stop the configuration.

PROGRAM:

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname karthi

karthi(config)#exit

karthi#

%SYS-5-CONFIG_I: Configured from console by console

karthi#clock set ?

hh:mm:ss Current Time

karthi#clock set ?

hh:mm:ss Current Time

karthi#clock set 10:50:30 ?

<1-31> Day of the month

MONTH Month of the year

karthi#clock set 10:50:30 july 5 2017 ?

<cr>

karthi#clock set 10:50:30 july ?

<1-31> Day of the month

karthi#clock set 10:50:30 july 5 ?

<1993-2035> Year

karthi#clock set 10:50:30 july 5 2017 ?

<cr>

karthi#clock set 10:50:30 july 5 2017

karthi#conf t

Enter configuration commands, one per line. End with CNTL/Z.

karthi(config)#enable password ?

7 Specifies a HIDDEN password will follow

LINE The UNENCRYPTED (cleartext) 'enable' password

level Set exec level password

karthi(config)#enable password gk

karthi(config)#line console 0

karthi(config-line)#login

% Login disabled on line 0, until 'password' is set

karthi(config-line)#password gk

karthi(config-line)#exit

karthi(config)#exit

karthi#

%SYS-5-CONFIG_I: Configured from console by console

karthi#copy run start

Destination filename [startup-config]?

Building configuration...

[OK]

karthi#en

karthi#exit

karthi con0 is now available

Press RETURN to get started.

User Access Verification

Password:

karthi>en

Password:

karthi#conf t

Enter configuration commands, one per line. End with CNTL/Z.

karthi(config)#

OUTPUT:

3.CONNECT, CONFIGURE AND VERIFY OPERATIONS STATUS OF DEVICE INTERFACE

AIM :

To connect configuration and verify operation status of device interface.

ALGORITHM :

STEP 1: To start the configuration.

STEP 2: Connect two routers using serial port.

STEP 3: Set interface for the faster Ethernet.

STEP 4: Change the interface state.

STEP 5: Set the clock rate speed.

STEP 6: Send the packet from one router to another router.

PROGRAM:

CODING:

Router>en

Router#conft

Enter configuration commands,one per line.End with CNTL/Z.

Router(config)#hostname rahim

rahim(config)#interface?

interface

rahim(config)#interface fastEthernet0/0

rahim(config-if)#ip address 91.0.0.1.255.o.o.o

rahim(config-if)#no shutdown

%LINK-5-CHANGEED:Interface FastEthernet0/0,changeed state to up

%LINEPROTO-5-UPDOWN:Line protocol on Interface FastEthernet0/0,changed state to up

rahim(config-if)#exit

rahim(config-if)#int f0/1

rahim(config-if)#ip address 92.0.0.1 255.0.0.0

rahim(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1,changed state to up

%LINEPROTO-5-UPDOWN:Line protocol on Interface FastEthernet0/1,changed state to up

rahim(congig-if)#exit

rahim(congig)#int serial0/0/0.

rahim(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0,changed state to down

rahim(config-if)#ip address 93.0.0.1 255.0.0.0

rahim(config-if)#no shutdown

rahim(config-if)#int serial0/0/1

rahim(config-if)#ip address 94.0.0.1 255.0.0.0

rahim(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1,changed state to down

rahim(config-if)#exit

rahim(config)#Line

%Incomplete command.

rahim(config)#Line?

<0-81> First Line number

cosole primary teminal line

vty Virtual terminal

rahim(config)#line console 0

rahim(config-line)#login

%Login disabled on line 0,util'password'is set

rahim(config-line)#exit

rahim(config#line vty?

<0-15> First Line number

rahim(config)#exit

OUTPUT:

4. IMPLEMENTATION STATIC ADDRESSING SERVICES FOR HOSTS IN A LAN ENVIRONMENT

AIM:

To implement static addressing services for host.

ALGORITHM:

STEP 1: Start the configuration.

STEP 2: Create the topology with router 1841.

STEP 3: Enter the user mode and then go to privilege mode.

STEP 4: Go to global configuration terminal command .

STEP 5: Use the IP address for serial port for the router.

STEP 6: Set the username and password .

STEP 7: Send the message from one router to another file its shows successfully.

STEP 8: Exit from the configuration mode.

STEP 9: Stop the configuration.

PROGRAM:

ROUTER 1

Router>en

Router#conf t

Enter configuration commands,one per line.End with CNTL/Z.

Router(config)#hostname R1

R1(config)#int f0/0

R1(config-if)#ip address 10.0.0.1 255.0.0.0

R1(config-if)#no shut

R1(config-if)#no shutdown

%LINK-5-CHANGED:Interface FastEthernet0/0,changed state to up

%LINEPROTO-5-UPDOWN:Line protocol on Interface FastEthernet0/0,changed state to up

R1(config)#exit

R1(config-if)#int s0/0/0

R1(config-if)#ip address 20.0.0.1 255.0.0.0

R1(config-if)#no shut

R1(config-if)#no shutdown

%LINK-5-CHANGED:Interface serial0/0/0,changed state to down

R1(config-if)#encap?

encapsulation

R1(config-if)#encapsulation ppp

R1(config-if)#username R2 password cisco

R1(config)#exit

R1#

%SYS-5-COUNFIG_1:configured from console by console

R1#

R1#conf t

Enter configuration commands, one per line.End with CNTL/Z.

R1(config)#int s0/0/0

R1(config-if)#clock rate 9600

R1(config-if)#exit

R1(config)#

ROUTER 2

Router>en

Router#conf t

Enter configuration commands,one per line.End with CNTL/Z.

Router(config)#hostname

%Incomplete command.

Router(config)#hostname R2

R2(config)#int f0/0

R2(config-if)#ip address 30.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED:Interface FastEthernet0/0,changed state to up

%LINEPROTO-5-UPDOWN:Line protocol on Interface FastEthernet0/0,changed state to up

R2(config-if)#int f0/0

R2(config-if)#ip address 20.0.0.2 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED:Interface Serial0/0/0,changed state to up

%LINEPROTO-5-UPDOWN:Line protocol on Interface Serial0/0/0,changed state to up

R2#conf t

Enter configuration commands,one per line.End with CNTL/Z.

R2(config-router)#exit\

OUTPUT:

5. IDENTIFY AND CORRECT COMMON PROBLEM ASSOCIATED

WITH IP ADDRESSING AND HOST CONFIGURATION

AIM :

To create a IP addressing and host configuration

ALGORITHM :

STEP1:Start the configuration

STEP2:Create the topology with route 1841.

STEP3:Enter the user mode and then go to privilege mode.

STEP4:Go to global configuration terminal command.

STEP5:Use the IP address for serial port for the router

STEP6:Set the user name and password(r1.cisco)

STEP7:Send the message from one router to another file its shows successfully.

PROGRAM:

Router>en

Router#conf t

Enter configuration commands,one per line.End with CNTL/Z.

Router(config)#int f 0/0

Router(config-if)#ip address 10.0.0.1 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED:Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN:Line protocol on Interface FastEthernet0/0,changed state to up

Router(config-if)#int f 0/1

Router(config-if)#ip address 20.0.0.1 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface fastethernet0/1,changed state to up

%LINEPROTO-5-UPDOWN:Line protocol on Interface FastEthernet0/1,changed state to up

Router(config-if)#

Router#

%SYS-5-CONFIG_I:Configured from console by console

OUTPUT:

6. BASIC ROUTING CONCEPTS IN CONFIGURING NAT

AIM :

To configure verify and trouble shoot the NAT operation on router.

ALGORITHM :

STEP 1: Start the program.

STEP 2: Create a topology with two router’s and 4pc’s.

STEP 3: Assign address for interface and pc’s.

STEP 4: Set IP NAT inside and outside command for interface.

STEP 5: Create IP NAT pool with the range of address.

STEP 6: Set the range of address to permit by using access-list command.

STEP 7: Map the list and pool.

STEP 8: Verify and troubleshoot the configuration using ping command.

STEP 9: Stop the program.

PROGRAM:

ROUTER 1:

Router> en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#int f0/0

R1(config-if)#ip address 10.0.0.1 255.0.0.0

R1(config-ip)#no shutdown

%LINK-5-CHANGED:Interface FastEthernet0/0,changed state to up

%LINEPROTO-5-UPDOWN:Line protocol no Interface FastEthernet0/0,changed state to up

R1(config-if)#exit

R1(config-if)#int s0/0/0

R1(config-if)#ip address 20.0.0.1 255.0.0.0

R1(config-ip)#no shutdown

%LINK-5-CHANGED:Interface Serial0/0/0,changed state to down

R1(config-if)#encap?

Encapsulation

R1(config-if)#encap

R1(config-if)# encapsulation ppp

R1(config-if)#username R2 password cisco

R1(config-if)#exit

R1#

%LINK-5-CHANGED:Interface Serial0/0/0,changed state to up

R1#conf t

Enter configuration commands, one per line. End with CNTL/Z.

R1(config-if)#int s0/0/0

R1(config-if)#clock rate ?

Speed (bits per second

1200

2400

4800

19200

38400

56000

64000

72000

125000

128000

148000

250000

500000

800000

1000000

1300000

2000000

4000000

<300-4000000> Choose clockrate from list above

R1(config-if)#clock rate 9600

R1(config-if)#exit

R1(config)#

%LINEPROTO-5-UPDOWN:Line protocol no Interface Serial0/0/0,changed state to up

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#network 10.0.0.0

R1(config-router)#network 30.0.0.0

R1(config-router)#exit

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#network 20.0.0.0

R1(config-router)#exit

R1(config)#

ROUTER 2:

Router> en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#int f0/0

R2(config-if)#ip address 30.0.0.1 255.0.0.0

R2(config-ip)#no shutdown

%LINK-5-CHANGED:Interface FastEthernet0/0,changed state to up

%LINEPROTO-5-UPDOWN:Line protocol no Interface FastEthernet0/0,changed state to up

R2(config-if)#int s0/0/0

R2(config-if)#ip address 20.0.0.2 255.0.0.0

R2(config-ip)#no shutdown

%LINK-5-CHANGED:Interface Serial0/0/0,changed state to down

R2(config-if)#encap

R2(config-if)# encapsulation ppp

R2(config-if)#username R1 password cisco

R2(config-if)#exit

R2#

%SYS-5-CONFIG_I:Configuration from console by console

R2#

%LINEPROTO-5-UPDOWN:Line protocol no Interface Serial0/0/0,changed state to up

R2#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#router rip

R2(config-router)#version 2

R2(config-router)#network 10.0.0.0

R2(config-router)#network 20.0.0.0

R2(config-router)#network 30.0.0.0

R2(config-router)#exit

R2(config)#

OUTPUT:

7.CONFIGURE VERIFY AND TROUBLESHOOT RIP V2

AIM :

To create an interface configuration for RIP v2 Connection.

ALGORITHM :

STEP 1: Connect two routers using serial port WIC-2t.

STEP 2: Using cable serial DIE communication with the router.

STEP 3: Set interface for the faster Ethernet.

STEP 4: Change the interface state.

STEP 5: Set the clock rate speed in the PPP authentication.

STEP 6: Send the packet from one router to the other router.

PROGRAM:

ROUTER 1:

Router> en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#int f0/0

R1(config-if)#ip address 10.0.0.1 255.0.0.0

R1(config-ip)#no shutdown

%LINK-5-CHANGED:Interface FastEthernet0/0,changed state to up

%LINEPROTO-5-UPDOWN:Line protocol no Interface FastEthernet0/0,changed state to up

R1(config-if)#exit

R1(config-if)#int s0/0/0

R1(config-if)#ip address 20.0.0.1 255.0.0.0

R1(config-ip)#no shutdown

%LINK-5-CHANGED:Interface Serial0/0/0,changed state to down

R1(config-if)#encap?

Encapsulation

R1(config-if)#encap

R1(config-if)# encapsulation ppp

R1(config-if)#username R2 password cisco

R1(config-if)#exit

R1#

%SYS-5-CONFIG_I:Configuration from console by console

R1#

%LINK-5-CHANGED :Interface Serial0/0/0,changed state to up

R1#conf t

Enter configuration commands, one per line. End with CNTL/Z.

R1(config-if)#int s0/0/0

R1(config-if)#clock rate ?

Speed (bits per second

1200

2400

4800

19200

38400

56000

64000

72000

125000

128000

148000

250000

500000

800000

1000000

1300000

2000000

4000000

<300-4000000> Choose clockrate from list above

R1(config-if)#clock rate 9600

R1(config-if)#exit

R1(config)#

%LINEPROTO-5-UPDOWN:Line protocol no Interface Serial0/0/0,changed state to up

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#network 10.0.0.0

R1(config-router)#network 30.0.0.0

R1(config-router)#exit

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#network 20.0.0.0

R1(config-router)#exit

R1(config)#

ROUTER 2:

Router> en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#int f0/0

R2(config-if)#ip address 30.0.0.1 255.0.0.0

R2(config-ip)#no shutdown

%LINK-5-CHANGED:Interface FastEthernet0/0,changed state to up

%LINEPROTO-5-UPDOWN:Line protocol no Interface FastEthernet0/0,changed state to up

R2(config-if)#int s0/0/0

R2(config-if)#ip address 20.0.0.2 255.0.0.0

R2(config-ip)#no shutdown

%LINK-5-CHANGED:Interface Serial0/0/0,changed state to down

R2(config-if)#encap

R2(config-if)# encapsulation ppp

R2(config-if)#username R1 password cisco

R2(config-if)#exit

R2#

%SYS-5-CONFIG_I:Configuration from console by console

R2#

%LINEPROTO-5-UPDOWN:Line protocol no Interface Serial0/0/0,changed state to up

R2#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#router rip

R2(config-router)#version 2

R2(config-router)#network 10.0.0.0

R2(config-router)#network 20.0.0.0

R2(config-router)#network 30.0.0.0

R2(config-router)#exit

R2(config)#

OUTPUT:

8. PERFORM AND VERIFY ROUTING CONFIGURATION TASKS

FOR A DEFAULT ROUTE

AIM :

To create a DEFAULT addressing for a default route.

ALGORITHM :

STEP 1: Start the configuration.

STEP 2: Assign the IP address for f/a is a De by using DEFAULT.

STEP 3: Change the hostname in configuration mode.

STEP 4: By using DEFAULT pool give the network address.

STEP 5: By using DEFAULT execute command reserved the address.

STEP 6: Copy the configuration by using copy run start.

STEP 7: Stop the process.

PROGRAM:

Router0:

Router>en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname mca

mca(config)#int se0/1/0

mca(config-if)#ip address 20.128.0.1 255.192.0.0

mca(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down

mca(config-if)#exit

mca(config)#int se0/1/0

mca(config-if)#ip address 20.0.0.2 255.192.0.0

mca(config-if)#encapsulation ppp

mca(config-if)#ppp authentication chap

mca(config-if)#username mca password cisco

mca(config)#int se0/0/0

%Invalid interface type and number

mca(config)#int se0/1/0

mca(config-if)#no shutdown

mca(config-if)#no shutdown

mca1(config)#ip route 0.0.0.0 0.0.0.0 se0/1/0

%Default route without gateway, if not a point-to-point interface, may impact performance

mca(config-if)#exit

mca(config)#exit

mca#

%SYS-5-CONFIG_I: Configured from console by console

Router 1:

Router>en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname mca

mca(config)#int fa0/0

%Invalid interface type and number

mca(config)#int fa0/0

%Invalid interface type and number

mca(config)#int se0/1/0

mca(config-if)#ip address 20.128.0.1 255.192.0.0

mca(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down

mca(config-if)#exit

mca(config)#int se0/1/0

mca(config-if)#ip address 20.0.0.2 255.192.0.0

mca(config-if)#encapsulation ppp

mca(config-if)#ppp authentication chap

mca(config-if)#username mca password cisco

mca(config)#int se0/1/0

mca(config-if)#no shutdown

mca(config-if)#no shutdown

mca(config-if)#exit

mca1(config)#int se0/1/0

mca1(config-if)#ip address 20.64.0.1 255.192.0.0

mca1(config-if)#clock rate 1200

This command applies only to DCE interfaces

mca1(config-if)#encapsulation ppp

mca1(config-if)#username mca1 password cisco

mca1(config)#int se0/1/0

mca1(config-if)#no shutdown

mca1(config-if)#no shut

mca1(config-if)#exit

mca1(config)#ip route 0.0.0.0 0.0.0.0 se0/1/0

%Default route without gateway, if not a point-to-point interface, may impact performance

mca1(config)#exit

mca1#

%SYS-5-CONFIG_I: Configured from console by console

mca1#

OUTPUT:

9.CONFIGURE VERIFY AND TROUBLESHOOT DYNAMIC ADDRESSING DHCP

AIM :

To create a Dynamic addressing for DHCP.

ALGORITHM :

STEP 1: Start the configuration.

STEP 2: Asssign the IP address for f/a is a Dc by using DHCP.

STEP 3: Change the hostname in configuration node.

STEP 4: By using DHCP pool give the network address.

STEP 5: By using DHCP execute command reserved the address.

STEP 6: Copy the configuration by using copy run start.

STEP 7: Stop the process.

PROGRAM:

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: n

Press RETURN to get started!

Router>en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int fa0/0

Router(config-if)#ip address 10.0.0.1 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#ip dhcp pool suresh

Router(dhcp-config)#network 10.0.0.0 255.0.0.0

Router(dhcp-config)#default-router 10.0.0.1

Router(dhcp-config)#exit

Router(config)#ip dhcp ex?

excluded-address

Router(config)#ip dhcp ex?

excluded-address

Router(config)#ip dhcp excluded-address10.0.0.1 10.0.0.10

^

% Invalid input detected at '^' marker.

Router(config)#ip dhcp ex?

excluded-address

Router(config)#ip dhcp excluded-address 10.0.0.1 10.0.0.10

Router(config)#exit

Router#

%SYS-5-CONFIG_I: Configured from console by console

Router#copy run start

Destination filename [startup-config]?

Building configuration...

[OK]

Router#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet0/0

Router#%IP-4-DUPADDR: Duplicate address 10.0.0.1 on FastEthernet0/0, sourced by 0060.2F80.5BB9

OUTPUT:

10. CONFIGURE VERIFY A PPP CONNECTION BETWEEN ROUTERS