CODES and Configurations

Switch Configuration AND Router Configuration

  • Manufacture
  • Configure hostname

config t

hostname swa

  • Configure password

config t

enable secret hello

write mem

  • Configure telnet

config t

line vty 0 4

password howdy

  • Configure IP Address

config t

int vlan 1

ip addr 192.168.1.1 255.255.255.0

no shut

  • Configure Port Forward Link Speed to 10 Mbps

config t

interface fastEthernet 0/24

speed 10

  • Configure Port Forward Link Speed to 100 Mbps

config t

interface fastEthernet 0/24

speed 100

  • Configure Bridge Priority in such a way SWA is Root for VLAN 1

config t

span vlan 1 priority 4096

  • Configure Switch Trunk Modeconfig t

interface fastEthernet 0/1

switchport mode trunk

interface fastEthernet 0/24

switchport mode trunk

  • Configure DNS server

config t

ip name-server 192.168.1.100

  • Configure VTP

config t

vtp domain DomXYZ

vtp password hello

vtp pruning

  • Configure ports to VLANs

config t

int fastethernet 0/6

switchport access vlan 1

  • Configure Etherchannel

config t

int fastethernet 0/1

channel-group 1 mode desirable

int fastethernet 0/2

channel-group 1 mode desirable

Ctrl-Z

config t

int port-channel 1

switch mode trunk

Ctrl-Z

config t

int fastethernet 0/23

channel-group 2 mode desirable

int fastethernet 0/24

channel-group 2 mode desirable

Ctrl-Z

config t

int port-channel 2

switch mode trunk

Ctrl-Z

  • Company first switch
  • Configure hostname

config t

hostname swa

  • Configure password

config t

enable secret hello

write mem

  • Configure telnet

config t

line vty 0 4

password howdy

  • Configure IP Address

config t

int vlan 1

ip addr 192.168.1.2 255.255.255.0

no shut

  • Configure Port Forward Link Speed to 10 Mbps

config t

interface fastEthernet 0/24

speed 10

  • Configure Port Forward Link Speed to 100 Mbps

config t

interface fastEthernet 0/24

speed 100

  • Configure Bridge Priority in such a way SWA is Root for VLAN 1

config t

span vlan 1 priority 4096

  • Configure Switch Trunk Mode

config t

interface fastEthernet 0/1

switchport mode trunk

interface fastEthernet 0/24

switchport mode trunk

  • Configure ports to VLANs

config t

int fastethernet 0/6

switchport access vlan 2

int fastethernet 0/6

switchport access vlan 3

  • Configure Etherchannel

config t

int fastethernet 0/1

channel-group 1 mode desirable

int fastethernet 0/2

channel-group 1 mode desirable

Ctrl-Z

config t

int port-channel 1

switch mode trunk

Ctrl-Z

config t

int fastethernet 0/23

channel-group 2 mode desirable

int fastethernet 0/24

channel-group 2 mode desirable

Ctrl-Z

config t

int port-channel 2

switch mode trunk

Ctrl-Z

  • Company second switch
  • Configure hostname

config t

hostname swa

  • Configure password

config t

enable secret hello

write mem

  • Configure telnet

config t

line vty 0 4

password howdy

  • Configure IP Address

config t

int vlan 1

ip addr 192.168.1.3 255.255.255.0

no shut

  • Configure Port Forward Link Speed to 10 Mbps

config t

interface fastEthernet 0/24

speed 10

  • Configure Port Forward Link Speed to 100 Mbps

config t

interface fastEthernet 0/24

speed 100

  • Configure Bridge Priority in such a way SWA is Root for VLAN 1

config t

span vlan 1 priority 4096

  • Configure Switch Trunk Mode

config t

interface fastEthernet 0/1

switchport mode trunk

interface fastEthernet 0/24

switchport mode trunk

  • Configure Etherchannel

config t

int fastethernet 0/1

channel-group 1 mode desirable

int fastethernet 0/2

channel-group 1 mode desirable

Ctrl-Z

config t

int port-channel 1

switch mode trunk

Ctrl-Z

config t

int fastethernet 0/23

channel-group 2 mode desirable

int fastethernet 0/24

channel-group 2 mode desirable

Ctrl-Z

config t

int port-channel 2

switch mode trunk

Ctrl-Z

Company

  • Configure hostname

config t

hostname swa

  • Configure password

config t

enable secret hello

write mem

  • Configure telnet

config t

line vty 0 4

password howdy

  • Configure IP Address

config t

int vlan 1

ip addr 192.168.1.4 255.255.255.0

no shut

  • Configure Port Forward Link Speed to 10 Mbps

config t

interface fastEthernet 0/24

speed 10

  • Configure Port Forward Link Speed to 100 Mbps

config t

interface fastEthernet 0/24

speed 100

  • Configure Bridge Priority in such a way SWA is Root for VLAN 1

config t

span vlan 1 priority 4096

  • Configure Root Guard

config t

interface fastEthernet 0/24

spanning-tree rootguarg

  • Configure Switch Trunk Mode

config t

interface fastEthernet 0/1

switchport mode trunk

interface fastEthernet 0/24

switchport mode trunk

  • Configure Etherchannel

config t

int fastethernet 0/1

channel-group 1 mode desirable

int fastethernet 0/2

channel-group 1 mode desirable

Ctrl-Z

config t

int port-channel 1

switch mode trunk

Ctrl-Z

config t

int fastethernet 0/23

channel-group 2 mode desirable

int fastethernet 0/24

channel-group 2 mode desirable

Ctrl-Z

config t

int port-channel 2

switch mode trunk

Ctrl-Z

  1. Router Configuration
  • Company Router 1
  • Configure hostname

config t

hostname Company1

  • Configure password

config t

enable secret hello

write mem

  • Configure telnet

config t

line vty 0 4

password howdy

  • Configure IP Address

config t

interface Ethernet0

ip addr 192.168.1.1 255.255.255.0

interface Ethernet1

ip addr 208.216.164.2 255.255.255.0

no shut

  • Company Router 2
  • Configure hostname

config t

hostname Company2

  • Configure password

config t

enable secret hello

write mem

  • Configure telnet

config t

line vty 0 4

password howdy

  • Configure IP Address

config t

interface Ethernet0

ip addr 192.168.1.10 255.255.255.0

interface Ethernet1

ip addr 208.216.164.20 255.255.255.0

no shut

  • Manufacture
  • Configure hostname

config t

hostname Manufacture

  • Configure password

config t

enable secret hello

write mem

  • Configure telnet

config t

line vty 0 4

password howdy

  • Configure IP Address

config t

interface Ethernet0

ip addr 192.168.1.30 255.255.255.0

interface Ethernet1

ip addr 208.216.164.30 255.255.255.0

no shut

  • Company
  • Configure hostname

config t

hostname Company

  • Configure password

config t

enable secret hello

write mem

  • Configure telnet

config t

line vty 0 4

password howdy

  • Configure IP Address

config t

interface Ethernet0

ip addr 192.168.1.40 255.255.255.0

interface Ethernet1

ip addr 208.216.164.40 255.255.255.0

no shut