VPLS implementation

To illustrate the flexibility of how you can connect CE devices, the configuration example uses different switch port modes and service-delimiting VLAN tags on each PE router as follows:

·  CE1 sends and receives untagged Ethernet packets that is, null service-delimiting VLAN tags. PE1 configures the switch port mode as dot1q-tunnel to forward packets that have an unmodified Ethernet header. The internal VLAN that is associated with the switch port is 2.

·  CE2 sends and receives tagged Ethernet VLAN packets of which the service-delimiting VLAN tag is 4. PE2 configures the switch port mode as a trunk to remove or add the service-delimiting VLAN tag accordingly. The internal VLAN that is associated with the switch port is 4.

·  CE3 sends and receives untagged Ethernet packetsthat is, null service-delimiting VLAN tags. PE2 configures the switchport mode as access to forward all untagged packets. The internal VLAN that is associated with the switchport is 8.

·  CE4 sends and receives tagged Ethernet VLAN packets of which the service-delimiting VLAN tag is 10. PE4 configures the switchport mode as a trunk to remove or add the service-delimiting VLAN tag accordingly. The internal VLAN that is associated with the switchport is 10.

Example 15-5 shows the configuration on PE1.

Figure 15-7. VPLS Configuration Example
Example 15-5. PE1 Configuration

hostname PE1

!

mpls label protocol ldp

mpls ldp logging neighbor-changes

mpls ldp router-id Loopback0

!

l2 vfi l2vpn manual

vpn id 1

neighbor 10.0.0.2 encapsulation mpls

neighbor 10.0.0.3 encapsulation mpls

neighbor 10.0.0.4 encapsulation mpls

!

interface Loopback0

ip address 10.0.0.1 255.255.255.255

!

interface POS3/1

ip address 10.0.1.1 255.255.255.252

mpls ip

!

interface FastEthernet4/2

no ip address

switchport

switchport access vlan 2

switchport mode dot1q-tunnel

!

interface Vlan2

no ip address

xconnect vfi l2vpn

Example 15-6 shows the configuration on PE2.

Example 15-6. PE2 Configuration

hostname PE2

!

mpls label protocol ldp

mpls ldp logging neighbor-changes

mpls ldp router-id Loopback0

!

l2 vfi l2vpn manual

vpn id 1

neighbor 10.0.0.1 encapsulation mpls

neighbor 10.0.0.3 encapsulation mpls

neighbor 10.0.0.4 encapsulation mpls

!

interface Loopback0

ip address 10.0.0.2 255.255.255.255

!

interface POS3/1

ip address 10.0.2.1 255.255.255.252

mpls ip

!

interface FastEthernet4/2

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 4

switchport mode trunk

!

interface Vlan4

no ip address

xconnect vfi l2vpn

Example 15-7 shows the configuration on PE3.

Example 15-7. PE3 Configuration

hostname PE3

!

mpls label protocol ldp

mpls ldp logging neighbor-changes

mpls ldp router-id Loopback0

!

l2 vfi l2vpn manual

vpn id 1

neighbor 10.0.0.1 encapsulation mpls

neighbor 10.0.0.2 encapsulation mpls

neighbor 10.0.0.4 encapsulation mpls

!

interface Loopback0

ip address 10.0.0.3 255.255.255.255

!

interface POS3/1

ip address 10.0.3.1 255.255.255.252

mpls ip

!

interface FastEthernet4/2

no ip address

switchport

switchport access vlan 8

switchport mode access

!

interface Vlan8

no ip address

xconnect vfi l2vpn

Example 15-8 shows the configuration on PE4.

Example 15-8. PE4 Configuration

hostname PE4

!

mpls label protocol ldp

mpls ldp logging neighbor-changes

mpls ldp router-id Loopback0

!

l2 vfi l2vpn manual

vpn id 1

neighbor 10.0.0.1 encapsulation mpls

neighbor 10.0.0.2 encapsulation mpls

neighbor 10.0.0.3 encapsulation mpls

!

interface Loopback0

ip address 10.0.0.4 255.255.255.255

!

interface POS3/1

ip address 10.0.4.1 255.255.255.252

mpls ip

!

interface FastEthernet4/2

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10

switchport mode trunk

!

interface Vlan10

no ip address

xconnect vfi l2vpn

You can examine the VFI using the command show vfi (see Example 15-9).

Example 15-9. Verifying the VFI Status

PE1#show vfi l2vpn

VFI name: l2vpn, state: up

Local attachment circuits:

Vlan2

Neighbors connected via pseudowires:

10.0.0.2 10.0.0.3 10.0.0.4

Table 15-1 lists the MAC addresses that are associated with each CE router. When a CE router also functions as an Ethernet switch, it bridges customer Ethernet traffic toward the attached PE router. In that scenario, the PE router learns multiple source MAC addresses from the CE router.

Table 15-1. MAC Addresses from CE Routers
/
Router / MAC Address /
CE1 / 000b.5fb5.0080
CE2 / 000b.5fad.e580
CE3 / 000b.5fb1.5780
CE4 / 000b.5fb1.5480

After full connectivity is established among all CE routers, every PE router should learn all MAC addresses from the CE routers. To verify the learning process on each PE router, use the command show mac-address-table vlan, as shown in Example 15-10.

Example 15-10. Verifying the Learning Process on Each PE Router

PE1#show mac-address-table vlan 2

Legend: * - primary entry

vlan mac address type learn ports

------+------+------+-----+------

* 2 000b.5fb5.0080 dynamic Yes Fa4/2

* 2 000b.5fad.e580 dynamic Yes

* 2 000b.5fb1.5780 dynamic Yes

* 2 000b.5fb1.5480 dynamic Yes

PE2#show mac-address-table vlan 4

Legend: * - primary entry

vlan mac address type learn ports

------+------+------+-----+------

* 4 000b.5fb5.0080 dynamic Yes

* 4 000b.5fad.e580 dynamic Yes Fa4/2

* 4 000b.5fb1.5780 dynamic Yes

* 4 000b.5fb1.5480 dynamic Yes

PE3#show mac-address-table vlan 8

Legend: * - primary entry

vlan mac address type learn ports

------+------+------+-----+------

* 8 000b.5fb5.0080 dynamic Yes

* 8 000b.5fad.e580 dynamic Yes

* 8 000b.5fb1.5780 dynamic Yes Fa4/2

* 8 000b.5fb1.5480 dynamic Yes

PE4#show mac-address-table vlan 10

Legend: * - primary entry

vlan mac address type learn ports

------+------+------+-----+------

* 10 000b.5fb5.0080 dynamic Yes

* 10 000b.5fad.e580 dynamic Yes

* 10 000b.5fb1.5780 dynamic Yes

* 10 000b.5fb1.5480 dynamic Yes Fa4/2

To display the status of the pseudowires that interconnect the virtual switches, use the command show mpls l2transport vc on PE routers, as shown in Example 15-11.

Example 15-11. Displaying the Status of the Pseudowires

PE1#show mpls l2transport vc

Local intf Local circuit Dest address VC ID Status

------

VFI l2vpn VFI 10.0.0.2 1 UP

VFI l2vpn VFI 10.0.0.3 1 UP

VFI l2vpn VFI 10.0.0.4 1 UP

Note: Here you can see there is no P router , But in real scenario you should use P for scalability. The P will work same as in MPLS network .